Quite Software  

You are here: Quite

 
         
   

Quite
Apple updates: Quite products and macOS "Monterey" and M1 Macs

Information updated 7 December 2021 with M1 native support info

What is macOS Monterey (macOS 11.0 or macOS 10.16)?

Monterey is the newest system for Apple Macs. It is also called macOS 12.0. It is the successor to "Big Sur". It is an optional upgrade available for most recent Macs. It was released on 25 October, 2021.

What are M1 Macs?

In 2020, Apple released a new line of Macs called “M1” which use an ARM chip instead of Intel. These require Big Sur or Monterey. (Earlier, these new Macs were announced as “Apple Silicon” but Apple no longer use that name). At the time of writing Apple sell a mixture of M1 and Intel Macs.

Can Quite Imposing Plus run "native" on M1 Macs

Yes! Starting with version 5.3, and recent Acrobat DC, Acrobat can run native on M1, and use Quite Imposing Plus, which is also native M1. Preference settings may be needed in Acrobat. Please see this page.

Should I upgrade to Monterey?

Before upgrading macOS, it's important to check for compatibility with all of your apps and plug-ins. It's also best to wait a while after a brand new major release, to allow other people to discover strange new problems with the new system, rather than affecting your own work. We can say for certain that Acrobat 11 (XI) and older versions cannot ever run on Monterey, and versions older than V5 of our products cannot run on Monterey.

For the status of Quite products see below.

Will Quite products work with Monterey?

Quite products up to and including 4.0 cannot be installed in Catalina. We have been testing our software with the new system, and the new Macs. We can report that:
  • Quite Hot Imposing 5.0f and above should run on M1 Macs, and on Monterey. There are no known issues, but older versions will not work correctly.
  • Quite Imposing Plus 5.2 has no known issues in Monterey. However, since Quite Imposing Plus is a plug-in for Acrobat, we recommend checking with Adobe before upgrading, to make sure that you can install and use Acrobat.
  • Other plug-ins, including Quite Imposing Plus 4, cannot be used.